Unknown user name or bad password

  • updated
  • Fixed
Hi guys...

I'm getting the "Unknown user name or bad password" error even though my login account exists.

Here is the scenario:

My weblog expert server has the 172.100.4.25 ip address and the one that i'm reading the logs have the 192.168.1.11 address.

Both servers are in different domains.

I have no problem reading the logs directly from the weblog server and the analyze button works great.

I don't have a mapped drive just to let you know.

When i try to run the schedule from the scheduler it gives me the error of bad username and password even though the settings are the same.

Please help me fix this.
Michael
The "Unknown user name or bad password" error is related to the username and password specified in the schedule settings, not the location of log files.

I recommend you to check the following topics, they have additional information and solutions on this issue:
https://getsatisfaction.com/weblogexp...
https://getsatisfaction.com/weblogexp...
Francisco
Hi Michael.

It helps but i've already try them...

This is my config

Please remember that this is another machine on another network and there is no chance to install new software since it's a critical production server.

Quick question....

If i'm able to read the logs remotely without problem, why the schedule, using the same account, can't work?.

Regards.
Francisco.
Michael
You should try either to set the account in the schedule options or in the service properties, not both. In most cases setting it in the schedule options should work. However, it seems that in this case there is indeed a problem with username and password, as the service manager also reports the logon error when it tries to start the service under this account.

It seems that the problem isn't with reading the logs, the problem appears because the scheduler cannot run the analyzer under your account, and it needs it to be able to access network and read logs from remote computer.

You should recheck that you use the username and password from the computer where the schedule service is running. If it doesn't work, you should try to use another account on the same computer (if available) and/or enter account name in format DOMAIN\UserName.
Francisco
Hi!

The service is running, the logs can be read with no problem and the only local account available is Administrator.

I've already specified the account with DOMAIN\User, using nmmcppc\administrator.

The nmmcppc is the domain and since that doesn't exist on the local machine, it doesn't work.

If i can read the logs correctly, shouldn't the scheduler follow the same path to connect to the other server and create the report?.

Please help me fix this... actually this is why i bought the app :(
Michael
When you run the program manually, it runs under your account and so can read logs from remote computer. However, the scheduler works as a system service. System services work under a special local system account. They don't require a user to be logged in to work. However, the problem is that the local system account cannot access the network, so it is necessary to run the analyze under another account to allow it to read logs from the remote server.

It seems that there is a problem with permissions that doesn't allow the service to log under this account. Probably the administrator account isn't configured to allow logging to it from a service. You can fix the problem the following way:

1. Start the Local Security Settings MMC snap-in.
2. Expand Local Policies, and then click User Rights Assignment.
3. In the right pane, right-click Log on as a service, and then click Security.
4. Add the user to the policy, and then click OK.
5. Close the Local Security Settings MMC snap-in.

You can find additional information on it at http://support.microsoft.com/kb/259733 and http://social.msdn.microsoft.com/Foru...

Please note that it is also possible to use other schedulers, e.g. Windows Task Manager. However, if they run as system services, they will probably have the same problem, so you should try the solution mentioned above first.
Francisco
Hi!...

It was my mistake after all :(.

I was trying to log in using the remote credentials instead of the local ones hahah...

The schedule works amazingly great.

Thanks so much for your help.

Regards.
Francisco.